The latest version of WordPress is out. It’s recommended that everyone upgrade to the latest version because of a vulnerability on the xmlrpc.php file in the distribution. Or as a temporary fix, you can delete the xmlrpc.php file temporarily.

For upgrade instructions, go here.

Original announcement here.